Mikrotik – Exemplos PCQ


PCQ (Per Connection Queue) é uma fila que pode ser usada para uniformizar dinamicamente ou moldar o tráfego para vários usuários, usando pouca administração. É possível dividir os cenários PCQ em três grandes grupos: Igualdade de largura de banda para um determinado número de usuários; Alguma largura de banda distribuída com igualdade entre os usuários; Largura de banda desconhecida distribuída com igualdade entre os usuários.

Igualdade de largura de banda para um determinado número de usuários.

pcq.png

Existem duas formas de fazer isso: usando mangle e queue tree, ou, usando simple queue.

1. Marque todos os pacotes com packet-mark all:

/ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=all passthrough=no

2. Configurar dois queue types PCQ – um para download e outro para upload. Dst-address é classificador do tráfego de download do usuário, src-address para o tráfego de upload:

/queue type add name=”PCQ_download” kind=pcq pcq-rate=64000 pcq-classifier=dst-address
/queue type add name=”PCQ_upload” kind=pcq pcq-rate=32000 pcq-classifier=src-address

3. Finalmente, duas queue rules são necessárias, uma para download e um para upload:

/queue tree add parent=global-in queue=PCQ_download packet-mark=all
/queue tree add parent=global-out queue=PCQ_upload packet-mark=all

Se você não gosta de usar mangle ou queue tree, você pode ignorar esta etapa 1, mantendo as etapas 2 e 3 e passaria a criar uma simple queue como mostrado aqui:

/queue simple add queue=PCQ_upload/PCQ_download target-addresses=192.168.0.0/24

fonte: http://wiki.mikrotik.com/wiki/PCQ_Examples; tradução: Google; revisão: administrador.

2 Respostas para “Mikrotik – Exemplos PCQ”

  1. […] mais um blog do WordPress Assine BDI BBSHistóriaBookmarksLan HouseControlD Lan HouseMikrotikMikrotik – Exemplos PCQWordpressSuporteGeralPostagens ArquivadasBlog Navegação: Home / Blog, Mikrotik / Nova […]

  2. […] 3) Largura de banda desconhecida distribuída com igualdade entre os usuários. Referência: Mikrotik – Exemplos PCQ – BDI BBS Citar + Responder ao Tópico GA_googleFillSlot("720×90-before"); […]